Config LAG on WiSM


port-channel load-balance srd-dst-ip

interface Port-channel101
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
mls qos trust dscp
spanning-tree portfast
switch trun native vlan 5
switchport trunk allowed vlan all

int range gig 1/1-4
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no snmp trap link-status
mls qos trust dscp
no cdp enable
channel-group 101 mode on
switch trun native vlan 5
spanning-tree portfast
switchport trunk allowed vlan all

or
wism module controller 1 native-vlan 40
wism module controller 1 allowed-vlan native vlan id(40), vlan id1, vlan2, etc…
Depends of the IOS version.

If you do a show run, you don’t see the interfaces and portchannels, but you can verify this with :

show etherchannel summary
Flags: D – down P – bundled in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use N – not in use, no aggregation
f – failed to allocate aggregator

M – not in use, no aggregation due to minimum links not met
m – not in use, port not aggregated due to minimum links not met
u – unsuitable for bundling
d – default port

w – waiting to be aggregated
Number of channel-groups in use: 6
Number of aggregators: 6

Group Port-channel Protocol Ports
——+————-+———–+———————————————–
101 Po101(SU) – Gi1/1(P) Gi1/2(P) Gi1/3(P)
Gi1/4(P)
102 Po102(SU) – Gi1/5(P) Gi1/6(P) Gi1/7(P)
Gi1/8(P)

show etherchannel port-channel
Channel-group listing:
———————–

Group: 101
———-
Port-channels in the group:
———————-

Port-channel: Po101
————

Age of the Port-channel = 43d:03h:40m:43s
Logical slot/port = 14/3 Number of ports = 4
GC = 0x00000000 HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = –
Fast-switchover = disabled

Ports in the Port-channel:

Index Load Port EC state No of bits
——+——+——+——————+———–
3 11 Gi1/1 On 2
0 22 Gi1/2 On 2
1 44 Gi1/3 On 2
2 88 Gi1/4 On 2

Time since last port bundled: 13d:00h:25m:22s Gi1/1
Time since last port Un-bundled: 13d:00h:25m:26s Gi1/4

Tags:

About Joost van der Made

Me

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: